Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Terxon LX und der Datenbus
30-07-2016, 12:02
Beitrag: #1
Terxon LX und der Datenbus
Wer kennt das nicht. Da versucht man mit seinem LX Pferdchen einen Ausritt am Datenbus und immer wieder kommt es zu irgendwelchen Problemchen. Wie zum Beispiel , Modul oder Bedienteil(e) plötzlich abgemeldet, nicht mehr vorhanden, Anlage nicht mehr abzustellen oder reagiert nicht bei Codeeingabe und RFID Chips.
Das steht man dann in der Ecke wo man ungeniert versucht jede Maus zu melken um wenigstens noch ein Tröpfchen an irgendwas von Information zu bekommen.Big Grin

Zur Eingrenzung dieses Fehlers hat die LX im Menü eine Datenbuskontrolle.
Siehe Manual Seite 98 / Code 95-6. Hier erreicht man das Menü zur Anzeige der Busfehlerrate. Durch drücken von 1 und 2 lässt sich zwischen den beiden Datenbussen umschalten. Die Zähler lassen sich mit der 0 wieder zurückstellen.
Für eine funktionierende LX sollte die Busfehlerrate pro Tag 20 nicht überschreiten.
Ziel ist aber eine Fehlerrate von Null. Wenn hier schon mal was angezeigt wird war man wohl noch nie da und hat jemals resetiert oder es ist ordentlich was faul bei der Verkabelung.
Sollte in der Anzeige auch noch was von Lt Fehler stehen dann ist dieser, also ich habe es bis jetzt noch nie anders geschafft, nur mit einem Neustart der Anlage, zu entfernen. Vorausgesetzt der Datenbus läuft wirklich sauber. Also ordentliche Kabel verwenden und sauber klemmen ist oberstes Gebot. Womit wir dann beim ersten Thema wären.
Dem Anklemmen der Busleitung ;
Die Platine hat zwei Klemmstellen. Einmal Network IN und einmal Network OUT. Das bedeutet daher, die Module werden von der Anlage weg in Serie (hintereinander) geklemmt. Zuerst von der Zentrale auf ein Network IN und dann mit Network OUT auf das Network IN der nächsten Erweiterung und so weiter. Der Hersteller spricht zwar von einer Möglichkeit mit max vier Stichabgängen, aber fangt euch blos nichts damit an. Hier kommt nur wieder Ärger auf. Darum beschreibe ich auch nicht dieses vorgehen. Seitdem ich bei mir alles Seriell verdrahtet habe läuft es wirklich einwandfrei. Die einzelnen Anschlussleitungen an den Klemmen sollten so kurz wie möglich gehalten werden. Bei mir liegen die Adern max. 5cm frei von der Abmantelung. Um aber mit dem blanken Draht der Schirmung den Klemmpunkt erreichen zu können muss dieser natürlich länger sein. Daher schon vorher daran denken, sonst wirds wieder zum Löten, das Kabel insgesamt etwas länger abzumanteln und dann die vier Drähte einfach auf die 5cm kürzen. Dann gibt es keinen Stress mir dem Verbinden. Ich habe das bei mir bei den Drahterweiterungen immer unten am Gehäuse in der linken oder rechten Ecke ausgeführt. Da lässt sich auch sehr schön eine Wagoklemme 222-412 verstecken. Die blanken Drähtchen gemeinsam ein wenig verdrillen und dann in nur eine Klemmstelle einführen, Schnapphebel der Klemme zu und es hält.
Kommt wieder was dazu einfach Hebel auf, neuen Draht mit verdrillen und wieder einschnappen lassen.

Wie gehts nun weiter?
Um festzustellen mit welcher Schweinerei wir zu tun haben brauchen wir ein Multimeter. Ich schicke aber jetzt folgendes ganz dick voraus:
!!!!!!!
Ich übernehme keine Haftung für das was hier jemand an möglichen Schaden irgend welcher Art anrichtet. Es ist daher jeder selbst verantwortlich für sein Handeln und jeder muss selber wissen ob er sich das zutraut. Ein falscher Messpunkt und es knallt. Ist das klar? Ansonsten lasst das einen E-Techniker machen.
!!!!!!!!

Oftmalig kann auch die Spannungsversorgung der Module ein Problem machen. Der Spannungsabfall in den Datenbusleitungen wird oft unterschätzt und dann kommt an so manchen Modul oder Bedienteil nicht mehr die wie beschrieben benötigte Mindestspannung von 10,5 V an......und genau hier sind wir jetzt an der Stelle wo uns der Hersteller die Augen zu tränen reibt. Den empfohlen wird eigentlich nicht unter 12V zu gehen. Das heißt im Umkehrschluss alles was unter 12V versorgt wird, wird langfristig zum Problem. Zum Beispiel bei intern Alarm wenn mehrere Bedienteile ihren Summer so richtig miteinander tröten lassen steigt der Stromverbrauch und dadurch sackt die Verrsorgung der Busleitung ab. Die Bedienteile zum Beispiel sagen Servus mit einem BDT abgemeldet und die Anlage hängt sich auf. Daher grundsätzlich mindestens die 12V einhalten. Gemessen zwischen A und B bei den einzelnen Drahterweiterungen und Bedienteilen. Bei größeren Objekten und längeren Busleitungen kommt man nicht hinweg ein Notstromnetzteil zur Versorgung der Drahterweiterungen einzuschleifen. Hiermit lässt sich dann auch der Spannungsabfall kompensieren. Was hierbei zu beachten ist steht im Manual der LX auf Seite 26. Angenehmer Nebeneffekt. Das Netzteil der LX wird gleichzeitig entlastet.
Wenn wir aber schon die Strippen in der Hand haben messen wir auch gleich die Sekundärspannung vom Trafo der Anlage. Das Teil was zu der LX-Platine den Saft bringt sozusagen. Hier sollten 17V bis 21V AC( Wechselspannung) vorhanden sein.
..
Was dem Datenbus auch noch sehr zusetzt sind Erdungsfehler, Potentialverschiebungen durch extern angeschlossene Geräte wie Notebooks über RS232 und induzierte Wechselspannung bei Kabelkreuzungen mit Elektroleitungen, längerer parallelverlauf oder einfach über oder neben diverser Geräten verlegt die entsprechende elektromagnetische Felder erzeugen.

Überprüfung auf Erdungsfehler:
1; Multimeter auf DC(Gleichspannung) mindestens 200V
2; Eine Messpitze auf AUX +12V ( Klemmleiste LX unten links)
3; Andere Messpitze auf die Erdungsklemme der LX
Befindet sich dort wo das Kabel zur 230V Netzversorgung angeschlossen ist in der Mitte. Adernfarbe Grün-Gelb. Hier bloß nichts verwechseln!
4, Die gemessene Spannung sollte unter 1V sein.
5; Selbige Messung auch zwischen AUX -12V und Erdung durchführen.
..
Werden mehr als 1V gemessen liegt ein Erdungsfehler vor. Dann einzeln Busteilnehmer abklemmen. Also Datenbusleitung verkürzen bis die Spannung unter 1V liegt . Da ist dann auch der Fehler zu finden.
.....
Überprüfung auf induzierte Wechselspannung:
1; Multimeter jetzt auf AC (Wechselspannung) mindestens 200V
2; Eine Messpitze auf AUX +12V ( Klemmleiste LX unten links)
3; Andere Messpitze auf die Erdungsklemme der LX
Befindet sich dort wo das Kabel zur 230V Netzversorgung angeschlossen ist in der Mitte. Adernfarbe Grün-Gelb.Hier bloß nichts verwechseln!
4, Die gemessene Spannung sollte unter 8v sein.
5; Selbige Messung auch zwischen AUX -12V und Erdung durchführen.

Sind hier mehr als 8V zu finden dann ebenfalls wieder Datenbusleitung durch abklemmen verkürzen bis die Spannung unter 8V geht. Der Fehler ist dann irgendwo dahinter zu finden. Kabelkreuzungen von elektr. Maschinen und Motoren oder auch Funkeinstreuungen, sowie Transformatoren sind beliebte Fehlerquellen.
Daher den Kabelschirm einseitig bei der Anlage immer schön auf Erdung klemmen hat bei mir Wunder gewirkt. Aber extra Erdungsklemme verwenden und nicht da bei der Netzversorgung mittig reinstopfen. Bei zusätzlichen Netzteilen hier auch wieder gesammelt mit Gehäuse erden.

..
Was aber sehr lustig ist sind mögliche Potentialverschiebungen durch angeschlossene externe Geräte. Das Notebook zum Beispiel per RS232. Treibt es nämlich bei beiden Messungen (Erdungsfehler und induzierte Wechselspannung) die Werte hoch, dann sitzt hier das Problem. Bei mir waren das an die gemessenen fast 30V. RS232 Stecker abgezogen und ich war wieder auf 0V.
Damit man hier klar Schiff macht gibt es die Möglichkeit der Galvanischen Trennung zwischen der Anlage und dem Rechner. Die Lösung hat Digitus mit dem Adapter RS232 zu TTL. Type DA-70163. Ist bei EBäh um ca. 13,50€ zu haben. Einfach zwischengesteckt und ferdich. Schützt nun auch zusätzlich umgekehrt den Rechner wenn die Anlage durch Spannungsspitzen hops geht. Was aber eigentlich nicht passieren sollte, denn wir haben ja für sowas eine USV vorgesehen. :-) Soll ja Leute geben die haben das Notebook dauernd an ihrer Ersatzeisenbahn stecken.Cool
..
Sodala das wars von mir. Sollte mir noch was dazu einfallen werd ich es einfach ergänzend anhängen. Wen es jemanden hilft solls mir recht sein. Ich sehs dann wie üblich an meiner Bewertung.Big Grin
Ja und nicht zu vergessen; Hat noch jemand etwas beizutragen dann bitte gerne mit zusätzlichem Posting anhängen. Bin ja auch nicht allwissend.
Letzte Textergänzung 01.08.16

DVR oder Cam hat Problem bei Fernzugriff? Mach zuerst einen Portcheck. Aber Sicherheit gibts nur mit VPN.
http://www.yougetsignal.com/tools/open-ports/
..und Terxonanlagen benötigen immer noch E-Technische Grundkenntnisse zur Installation und Inbetriebnahme.Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
30-07-2016, 21:14
Beitrag: #2
RE: Terxon LX und der Datenbus
So ich habe mal ein Bild (anbei als Attachement) von meinem Network 2 gemacht, da das sehr überschaubar ist Smile . Vielleicht bin ich ja auch einfach zu doof die 4 Drähte anzuschließen ?!

In der Überwachung wird für mein Funkmodul an Network 2 13,5V angezeigt. Spannung ist also ok.

Habe den ersten vorgeschlagenen Test gemacht. Ohne Netzanschluss, also nur mit Akku, bin ich unter bei ca. 0,4V. Sobald ich Netz anlege, spinnt mein Multimeter rum, da es nur eine Auto-Volt (DC/AC) Funktion hat und die Anzeige dann wild umher hüpft.
Die Frage ist, ob bei meiner "Buslänge" überhaupt ein Erdungsproblem auf dem Network 2 Bus vorliegen kann.

Könnte auch ein Erdungsproblem auf Network 1 oder anderen Anschlüssen dazu führen, dass der Network 2 rumspinnt???

Habe deshalb die Versorgung externer Geräte über Aux +12 V und 0V nach hinten komplett abgetrennt, aber das führte zum selbsen Zicken meines Multimeters, Evtl. ist das ja mal fällig.

Lasse nun auch mal die Funkerweiterung über Nacht dran, mal sehen, wieviel Busfehler ich morgen habe.


Angehängte Datei(en) Thumbnail(s)
   
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste